Windows Vista και memory usage

17 June 2006
20,760
Αθήνα
Οπως ξέρετε εδώ και λίγο καιρό παίζω με τα Vista.

Μετά από πειράματα με μνήμη έχω καταλήξει στα εξής αποτελέσματα :

Με 1 GB DDR2 667 είμαι στο 63% usage

Με 2 GB είμαι στο 37%

Με 3 GB είμαι στο 30%

Σε όλες τις περιπτώσεις μιλάω ΧΩΡΙΣ να τρέχει καμία εφαρμογή. Απλά υπάρχει μόνο το περιβάλλον των windows με το Aero και το sidebar.

Υπ' όψιν έχω κάρτα γραφικών με 256 MB που σε όλες τις περιπτώσεις την κάνει 512.

Τι γίνεται λοιπόν; όσο φορτώνεις μνήμη τόσο ρουφάει για το ΙΔΙΟ πράγμα;

Γιατί με 1GB χρησιμοποιεί 640MB μνήμης και με τα 3GB χρησιμοποιεί 940GB;
 
17 June 2006
20,760
Αθήνα
Με όλα τα παραπάνω ανοικτά

συν PowerDVD 7 full screen ταινία πήγε στα 1,19GB

Επιπλέον, ανοίγω Media player 11 full screen και παίζω HD κλιπάκι πήγε 1,28GB

Αρα, μου δείχνει ότι ναι μεν ξεκινάει χρησιμποιώντς πολούς πόρους μνήμης αλλά ΔΕΝ ανεβαίνει αντίστοιχα ανοίγοντας εφαρμογές.

Εγώ αυτό καταλαβαίνω.
 
Τα Vista, όπως και τα XP και τα 2000, κάνουν dynamic allocation της μνήμης. Αυτό σημαίνει, μεταξύ άλλων, και ότι δεσμεύουν ένα σημαντικό μέρος της μνήμης για caching του δίσκου. Αλλά, εάν αυτή η μνήμη ζητηθεί από κάποια εφαρμογή, την αποδεσμεύουν ακαριαία.

Οπότε, το νουμεράκι που βλέπουμε στο memory utilization είναι κατά ένα σημαντικό μέρος πλασματικό.

For the record, εγώ με 2GB RAM και ένα Firefox, Remote Desktop, Skype, Live Messenger, Winamp και κάτι άλλα ψιλά έχω utilization 42%, δηλαδή 840ΜΒ.
 

nikosfp

Established Member
1 December 2006
141
Πάτρα
Tασο καλημερα.Εχεις τα Ελληνικα Vista?Ολα τα προγραμματα,τα περιφερειακα,καρτες κ.λ.π. τ αναγνωρισαν και λειτουργουν σωστα?Να τα παρω η να περιμενω κανα 6μηνο?Ευχαριστω.
 

Babis K.

Super Moderator
Staff member
17 June 2006
24,253
Αθήνα
Εγώ μέχρι στιγμής δεν έχω κανένα πρόβλημα συμβατότητας με τα Vista στο Vaio που τα έχω βάλει.
Αναγνώρισαν τα πάντα.
Δεν έχω αρχίσει ακόμα να φορτώνω προγράμματα όπως Photoshop κλπ παρά μόνο τον Windows Live Messenger και το Skype που δουλεύουν άψογα.
Τα υπόλοιπα θα τα δούμε στην πορεία...
 

 Νίκος

Supreme Member
Σε φορτητό Averatec δεν βρήκε τίποτα αλλά ευτυχώς έβαλα τους drivers απο τα XP και ολα οκ.. Oμως με το που άνοιξε ο ΙΕ 7 και τίποτα άλλο γονάτησε το σύμπαν ... 512 ΜΒ ram τα έφαγε για πρωινό...
Και να πεις οτι βαζοντας μνήμη θα βελτιωθεί η κατασταση, με την Ati 200M Αero γιόκ...
Έχουν να πουληθούν φορητά από Γενάρη και μετά.......
 
Last edited: